徕卡三维激光扫描产品中文培训与文档中心

2024.1.0 | Cyclone 3DR Release Notes

中文 原文更新:— 查看英文原文 ↗

3DR 横幅

说明

2024 年 8 月 2 日

Cyclone 3DR 2024.1.0

新增功能

Cyclone 3DR 2024.1.0 是一个重要版本,包含针对该产品的新功能与改进,涵盖桌面版与 Touch Mode 两种界面。

主要变更和新功能概述如下:

  • Floor Flatness / Floor Levelness 分析,一个可执行符合 ASTM-E1155 标准分析的新工作流 [AEC Edition]
  • Scan to Pipe 中的后续功能 [Plant Edition]
  • 新资产:Y 型和 T 型支管
  • 异径管和弯头的自动拟合能力
  • 使用自由移动工具复制管道轨迹
  • 新的导出功能,包括将管道信息表导出为 CSV
  • 用户界面改进(撤销/重做、热键……)
  • Statistics,一个新的分析工具,可从任何类型的被分析对象中提取详细的表格和图表 [Standard Edition]
  • 点云分类 [Survey、AEC 或 Plant Edition]
  • 新版分类引擎,提供更快的性能:比 Cyclone 3DR 2024.0 快 20%
  • 专用于管道网络的新 Plant 分类模型
  • LGSx 集成更新 [Standard Edition]
  • 新的点云属性功能 [Standard Edition]
  • Separate by Attributes
  • 支持多次回波值
  • LAS/LAZ 格式导入更新
  • Connect to Reality Cloud Studio 更新
  • Inspection 和 Intensity 属性的改进
  • 扫描方向

使用仍受维护的 Cyclone MODEL 和 SURVEY 许可运行

随着 Cyclone 3DR 2024.1 的发布,该产品现在可由 Cyclone MODEL 和 SURVEY 许可激活,详见下文。这一变更让这些旧版产品的用户能够运行 Cyclone 3DR,以熟悉该产品并迁移其工作流。Cyclone MODEL 和 SURVEY 都将在 2025 年完全淘汰。

所有持有 Cyclone SURVEY 有效 CCP 或截至 2024 年 7 月 6 日有效的 CCP 的用户,均可运行此新版本的 Cyclone 3DR(仅限 Standard 和 Survey Edition 功能)。

所有持有 Cyclone MODEL 有效 CCP 或截至 2024 年 7 月 6 日有效的 CCP 的用户,均可运行此新版本的 Cyclone 3DR(仅限 Standard 和 Plant Edition 功能)。

Floor Flatness / Floor Levelness [ASTM E1155 标准]

Cyclone 3DR 现在包含一个遵循 ASTM 1155 标准的 Floor Flatness/Floor Levelness 例程。这一建筑市场高度需要的功能,确保用户可以直接在 Cyclone 3DR 中轻松创建其全套交付物,而不再需要额外的工具或产品来生成单独的分析。

向导引导的工作流会全程支持用户完成分析。

基本工作流如下。下文提供了完整说明。

  1. 选择一个点云。 - 请注意,像 LGSx 这样的 JetStream 点云,或从 Cyclone ENTERPRISE 或 Cyclone REGISTER 360 PLUS 流式传输的点云,无需转换。
  2. 从 Analysis 菜单执行 FF/FL Analysis。
  3. 执行引导流程的 5 个步骤(详见下文)。
  4. 打开报告编辑器以导出 PDF 文档。

此功能面向持有 AEC 或 PRO 许可的用户提供。

FF-FL 工作流

引导式工作流由 5 个步骤组成:

  1. 提取地面
  2. 定义测试曲面
  3. 定义测试剖面
  4. 定义取样线
  5. 调整取样线
说明

与 Cyclone 3DR 中所有向导引导的工作流一样,可以通过 Previous/Next 按钮或通过工作流 Ribbon 在流程中后退或前进。

该工作流在 Cyclone 3DR 2024.1 中仅依据 ASTM E1155 标准定义。

提取地面

此步骤帮助用户使用限界框定义一块干净的数据区域,并单击一次即可快速检测地面。此地面提取步骤允许用户无需任何事先的数据清理操作即可执行 FF/FL 分析。

说明

任何处于活动状态的限界框,若与活动 UCS 对齐并在开始工作流之前已被激活,则该限界框将被直接使用,而不会提示用户再次创建限界框。

image-20240701-141901.png

  1. 定义地面的容差提取(噪声点将在此第一步中被移除)。
  2. 工作流每个步骤的说明将显示在查看面板的左下角。请按照说明操作。
  3. 单击地面。

image-20240726-074426.png 4. 单击地面后,将创建一个智能限界框,以裁剪相关的地面点并排除场景的其余部分。 5. 单击 Compute 以启用地面检测,并仅保留与分析相关的点。

说明

关于 LGSx 和 JetStream 点云的说明:

  • 在开始执行 FF/FL Analysis 之前,无需转换 JetStream 点云。
  • 会公开一个附加参数,用于定义由一键地面提取所创建的智能限界框内的最大点数。建议使用较大的点数,以确保获得准确的 FF/FL 结果。

image-20240701-144729.png

定义测试曲面

此步骤允许用户创建一个依据 ASTM E1155 标准定义的测试曲面(Test Surface)。测试曲面的最小尺寸由 ASTM E1155 标准定义。

  • 测试曲面必须满足最小长度、宽度和面积要求。
  • 测试曲面定义了色图的区域。
  • 测试曲面可以包含多个测试剖面(见下一步)。通过在一个测试曲面中包含多个测试剖面,可为具有多个剖面的板块生成单一的地面分析报告。

image-20240701-144122.png image-20240726-071514.png

  1. 定义 FF/FL 的合同规范。最小局部值为可选项。当合同规范(ASTM E1155 要求)需要时,用户可以用其来计算最小值。
  2. 单击 Add,并通过在提取出的地面上单击 3 个点来定义代表测试曲面的矩形。
  3. 由于测试曲面的尺寸取决于 ASTM 标准要求,界面会向用户显示一个提示器,用于检查该曲面的最小尺寸(长度、宽度和面积)。
  4. 上图中的提示器为绿色,并在对话框中带有对勾标记。这表示剖面符合 ASTM 标准。当未满足要求时,提示器为红色。
  5. 如果尺寸要求不符合 ASTM 1155 标准,则无法创建测试曲面。
  6. 尺寸要求不可编辑。它们由 ASTM 1155 标准定义。
  7. 单击 Reset 可移除正在创建的测试曲面并重新开始。
说明

在创建测试曲面时按空格键,可从三次点击创建模式切换到两次点击创建模式。要使用此选项,请在开始工作流之前创建 UCS。

测试曲面尺寸不符合 ASTM 要求时的提示器 测试曲面尺寸符合 ASTM 要求时的提示器
image-20240726-072308.png image-20240726-072243.png
定义测试剖面

一旦定义了测试曲面,用户便可继续创建测试剖面。用户可以根据 ASTM 标准创建多个测试剖面,测试剖面需满足以下要求:

  • 它们必须保持在测试曲面之内。
  • 它们必须具有最小尺寸以保持合规。
  • 它们保持与测试曲面一致的对齐方式(剖面的平行性是强制的)。

image-20240701-150839.png image-20240726-072025.png

  1. 选择是否创建多个测试剖面。勾选 Use test surface as test section 复选框可在整个曲面上执行分析。
  2. 如果未勾选该选项,则可以添加多个测试剖面。单击 Add 开始向曲面添加剖面。
  3. 使用两次点击的方法在测试曲面内创建测试剖面。
  4. 如果不满足尺寸要求,则无法创建测试剖面。
  5. 如果有任何拾取点落在测试曲面之外,则无法创建测试剖面。
  6. 将显示分析的总面积,以帮助用户保持符合 ASTM 标准。
定义取样线

一旦定义了测试剖面,用户将创建符合 ASTM 标准的取样线。

image-20240701-152931.png

image-20240726-072953.png

  1. 定义使用哪种方法创建取样线架构
  2. 平行和垂直(ASTM 标准的要求)
  3. 45 度(或类似鱼骨状)。45 度方向是 ASTM 标准的要求
  4. 在选项中,可以:
  5. 更改取样线的数量(针对每个测试剖面)。为保持符合 ASTM 标准,可能需要添加更多线(在这种情况下会向用户发出警告)。
  6. 反转 45 度方法主线的方向。
  7. 当线条与已知障碍物(例如工地设备或孔洞)相交时,可以单击某条线并调整其位置以避开这些障碍物。(见下文)
  8. 请注意,ASTM 标准要求取样线均匀分布。
  9. 单击 Compute 以创建色图并计算每条取样线的 FF/FL 值。
  10. 用户可在后续操作中编辑色图的颜色。

ASTM FF/FL 工作流 04 取样线 04

调整取样线的位置:

在下面的示例中,很明显有些线穿过了孔洞,或位于点稀疏的区域。出现这种情况时,系统会自动检测到,并以红色突出显示问题和错误。

image-20240701-154459.png

  1. 错误消息用于通知用户。
  2. 在列表中,需要注意的剖面以红色 X 标示。
  3. 单击每条红线以调整其位置并避开障碍物。必须解决所有红线和错误,才能执行 FF/FL 分析。
  4. 向用户显示取样线均匀分布的要求。
结果

一旦创建了取样线且其符合要求,请查看分析结果并调整生成的标签。

image-20240701-154910.png

  1. 会显示用户定义的合同规范,以确保用户在查看结果时可以方便地参考它们。
  2. 总体值的结果:Overall FF 和 Overall FL。
  3. 绿色 “Check” 标记表示该值通过。
  4. 红色 “Cross” 标记表示该值未通过。
  5. 局部值的结果:显示 Local FF 和 Local FL 值,仅当用户在定义测试曲面步骤中定义了用于验证的最小值时,FAIL/PASS 标记才可见。单击表格的每一行可识别所引用的取样线。
  6. 场景中显示这些线条以及包含 FF/FL 值的标签。

ASTM FF/FL 工作流 05 结果 02ASTM FF/FL 工作流 05 结果 03

FF-FL 报告

分析完成后,会自动创建一个报告章节。报告可以以 PDF 或 CSV 报告的形式交付。

ASTM FF/FL 工作流 06 报告 02

PDF 报告包含以下默认章节:

  • 完整分析的摘要页(上图),由测试曲面定义,包含:
  • 完整的色图
  • 合同规范
  • FF/FL 值以及 PASS 或 FAIL 结论
  • 每个测试剖面一页
  • 如果用户选择了 Use test surface as test section,则将包含单个测试剖面页。
  • 每条取样线一页

ASTM FF/FL 工作流 06 报告 03

ASTM 合规性

在 Cyclone 3DR 2024.1 中,FF/FL 功能符合 E1155 ASTM 标准。这意味着:

  • 所有验证和计算均依据所定义的这一特定标准进行。
  • 强制使用适当的测试曲面和测试剖面参数。
  • 取样线只能以符合要求的方向创建。
  • 所有结果均以英制单位呈现。
  • 不支持用于 FF/FL 验证的 “ASTM 公制版本”。
说明

当 Cyclone 3DR 项目单位为公制时,仍可以执行该工作流。但是,无论项目单位如何,FF/FL 验证都将使用英制值进行。提醒一下,FF/FL 值是无单位的。最终报告中会说明验证使用的是 E1155 ASTM 标准。

Scan to Pipe 更新

在 Cyclone 3DR 2024.1 中,Scan to Pipe 工作流得到了进一步改进,详见下文。这些附加功能有助于提升 Scan to Pipe 工作流的效率和效果,使用户能够快速获得高质量的结果。

  • 新资产:Y 型和 T 型支管
  • 异径管和弯头的新自动拟合能力
  • 新的省时工具
  • 使用自由移动工具复制管道轨迹
  • 用户界面改进(撤销/重做、热键……)
  • 新的导出选项,包括将管道信息表导出为 CSV

此功能面向持有 Plant 或 PRO 许可的用户提供。

新资产:T 型和 Y 型支管

除已支持的直线段、弯头和异径管之外,Scan to Pipe 工作流现在还支持 T 型和 Y 型支管。界面会向用户显示一个新操作,用于选择合适的支管选项。

3DR Scan to Pipe 改进 UI 热键 4

要用 T 型或 Y 型支管连接两段轨迹或两段管路,用户将:

  • 第一,准备将要通过支管连接的两段轨迹。T 型和 Y 型支管不会自动放置。
  • 第二,核实轨迹的直径:请注意,连接在主轨迹中部的次级轨迹,其直径必须小于主轨迹(在连接区域)的直径。可以在对话框中的管道几何信息里编辑直径。
  • 第三,根据所连接两段轨迹的配置,通过以下两种工作流之一执行支管连接。

在轨迹中部添加支管

  1. 始终先从主轨迹中选择 “参考” 直管。
说明

请注意,在 Scan to Pipe 中,第一个被选中的对象始终是参考对象。

3DR ScanToPipe 支管 03a 裁剪图 2. 激活新模式 Connect with branches(热键 4) 3. 单击要连接的直管(次级轨迹)

image-20240722-081308.png 4. 按 ENTER 5. 支管将自动创建 6. 可使用编辑箭头来允许用户调整支管接头的尺寸 7. 两段轨迹将在 Scan to Pipe 项目中合并为一段轨迹。

image-20240722-081113.png

在两段轨迹的端部添加支管

  1. 选择主轨迹的端点,即 “参考” 端点(该段必须沿直线延伸)

image-20240617-114605.png 2. 激活新模式 Connect with branches(热键 4) 3. 单击次级轨迹的端点 4. 单击 Enter

image-20240617-114713.png 5. 支管将自动创建 6. 可使用编辑箭头来允许用户调整支管接头的尺寸。 7. 支管放置完成后,即可延伸该轨迹。

image-20240617-114744.png

与其他管道组件一样,支管:

  • 可以编辑:
  • 在对话框中使用数值编辑:直径(Extract)和厚度(Export)。
  • 在 3D 场景中使用箭头编辑。
  • 可以使用特定的 ifctype 导出,以在导出为 BIM 类型模型(ifc 格式)时保留支管信息:ifcflowfitting

image-20240617-115256.png

弯头和异径管的新自动拟合

在轨迹的半自动创建过程中,随着弯头和异径管自动拟合的加入,提取功能得到了显著改进。用户将立即受益于提取器更好的性能和所拟合组件更高的准确度,从而减少手动编辑并节省时间。

创建轨迹的流程没有变化。用户将先有一段已有的直线管路,然后双击异径管或弯头之后的下一段直线部分。现在,弯头或异径管将与下一段直线部分一起被自动拟合。

3DR ScanToPipe 改进 算法 异径管 01 之后

3DR ScanToPipe 改进 算法 异径管 01

复制轨迹

用户现在可以复制轨迹,以便快速复制在环境中重复出现的区段,从而节省用户时间并避免不必要的重复工作;也可用于某个重复出现的元素点密度不足、无法进行拟合的情况。

  1. 选择一段轨迹。
  2. 单击 Duplicate 复制一段轨迹。

image-20240726-074854.png 3. 系统会自动创建一个副本,并启用 “自由移动” 工具,让用户按需定位新轨迹。 4. 按照说明在 3D 环境中创建轨迹的副本。“复制工具” 小组件与应用程序中的 Free Move 命令是同一个工具。

说明

用户可以在复制轨迹工具中撤销和重做操作。

3DR ScanToPipe 复制轨迹 说明

当多段轨迹的某一部分完全相同且平行时,这一新功能非常有用。在这种情况下,建议先创建公共部分,然后复制相同的部分、对其进行定位,最后在相同部分之外继续各自的轨迹。此外,当点云在感兴趣区域非常稀疏时(这在非常密集的管道区域很常见),这一新模式也很有用。

3DR ScanToPipe 复制轨迹

image-20240617-112040.png

新的导出选项

Cyclone 3DR 2024.1 为管道模型提供了两个新的导出选项,如下所述。

“管道表格” 信息 [CSV]

现在,Scan to Pipe 工作流的 Export 步骤支持 CSV 格式,并可创建管道信息表格。这一新导出可以列出所有对象(名称和类型)及其几何信息(直径、厚度、坐标、角度 — 如果有)。

image-20240612-160345.png

此导出能力是对其他格式的补充,并带来了新的可能性,例如对模型进行 QA/QC 验证以及计算工程量,从而为最终用户提供更多信息。

3DR ScanToPipe 导出表格 01

导出带纹理网格模型的选项 [OBJ、GLB、FBX]

现在提供了一个新选项,在将模型导出为支持纹理的网格格式(obj、glb、fbx)时,可以根据点云颜色创建纹理。

此选项为 Scan to Pipe 工作流提供了一种省时且直接的带纹理网格导出方式。

image-20240612-160725.png

用户界面改进

撤销 / 重做

在工作流的提取和导出步骤中,现在可以从对话框中使用撤销/重做。这些命令也可以通过常用快捷键 CTRL+Z / CTRL+Y 访问。

image-20240617-113509.png

热键

在提取步骤中会向用户展示新的热键。热键的使用取决于用户处于工作流的哪个阶段。

热键 在主 3D 界面 / 无选择 在主 3D 界面 / 有选择 在管道提取期间
+ 开始新的管道轨迹
C 继续管道轨迹
1 连接 “弯头”(需要选择端点) 启用 “弯头 + 直管” 模式
2 连接 “异径管”(需要选择端点) 启用 “异径管 + 直管” 模式
3 连接 “直线部分”(需要选择端点) 启用 “直管” 模式
4 连接 “Y 型或 T 型支管”(需要选择直线部分)
D 复制所选的轨迹
Enter 验证轨迹
Del 删除所选组件

轨迹的多选

在 Scan to Pipe 工作流的提取步骤中,现在可以从树视图或 3D 场景中选择多段轨迹以进行批量编辑。这些多选的管道可以被删除,也可以更改其属性(例如直径)。

image-20240625-145202.png

选择要导出的内容

用户现在可以选择要导出哪些轨迹,而不必导出全部。要导出管道模型的子选集,用户可以勾选或取消勾选复选框。Export all / Export none 按钮有助于节省选择时间。

image-20240625-145403.png

3D 场景的更好同步

在 Scan to Pipe 工作流的 Export 步骤中,树视图与 3D 场景现在是永久同步的。在树视图中选择一个对象时,它会在场景中被选中,反之亦然。这为用户带来更好的 3D 体验,并让用户更容易根据树视图中可用的参数在 3D 场景中操作对象。

image-20240625-150733.png

点云分类

更新后的分类引擎

自 2021.2 版 Cyclone 3DR 首次发布点云分类以来,该引擎一直在定期改进,包括执行的耗时性能。在 2024.1 版本中,引入了新的分类引擎,相比之前的 Cyclone 3DR 2024.0 版本具有更好的性能。计算时间现在减少了约 20%。

要启用新引擎,组件的安装与上一版本相同。

  • 安装 Cyclone 3DR 2024.1 应用程序
  • 首次执行 Auto-Classification 以下载并安装分类包(包括 CUDA 驱动和新模型)
  • 重新启动 Cyclone 3DR 应用程序

此功能面向持有 Survey、AEC、Plant 或 PRO 许可的用户提供。

Plant 应用的新模型

借助新的分类引擎,现在提供了一个专为管道环境训练的新模型。在该模型的第一个版本中,重点放在 6 个不同的类别上:

  • 直圆柱
  • 弯曲圆柱
  • 异径圆柱
  • 连接件
  • 阀门
  • 未定义

这一新的 Plant 分类模型的一个有用应用,是在建模(网格化、Scan to Pipe 或分析)之前清理数据。

Plant 换热器 视图 A 分类

通常,用户会在进行 Scan to Pipe 作业之前从点云数据中移除未定义的点,以去除噪声、改善管道资产的可视化并简化提取。即使用户倾向于在提取过程之前保留未定义的点,可视化分类表示也非常有助于更好地理解数字现实。

ShowRoom 视图 A 分类

此功能面向持有 Survey、AEC、Plant 或 PRO 许可的用户提供。

Statistics

在 Cyclone 3DR 2024.1 中,Analysis 菜单中提供了一个新的统计功能。Statistics 可为应用程序中的所有分析工作流提供高级报告。

  1. 执行一个会生成被检查模型作为输出的分析工作流。被检查模型可以是网格/BIM/CAD/几何分析、点云、点网格(例如:Gridded Inspection)、多段线。
  2. 选择分析结果(从树视图或 3D 场景中)。
  3. 从 Analysis 菜单中选择 Statistics。
  4. 3D 场景会自动隐藏,以显示分析结果的直方图分布和最相关的统计值。
  5. 修改报告以适合项目需求。
    1. 编辑直方图的属性(颜色、带渐变的颜色、累积图等)。
    2. 创建新的报告章节。
    3. 导出详细报告,可以从报告编辑器导出离散化的 CSV 表格,让用户自行执行更高级的统计分析。
  6. 单击 OK 以验证 Statistics 操作。
  7. 打开 Report Editor,以查看和准备报告(PDF 或 CSV)。

此功能有助于完成高级分析,尤其是在需要依据标准或规范进行控制、从而必须证明详细分布的情况下。总体而言,这个新命令是一种用附加信息来补充传统 Cyclone 3DR 分析的方式。

3DR 2024.1 Statistics02

说明

关于点云的说明:此新功能基于点上的 inspection 属性工作。

在执行 Statistics 功能之前,必须先显示对象的 inspection 值。

不过,这个新命令还解锁了为其他标量值/属性创建统计的能力,例如 intensity、timestamps 或 density(请参阅 https://hexagon.atlassian.net/wiki/spaces/RCD/pages/edit-v2/44135007535#Separate-by-attributes)。

要进行这样的统计控制,必须在执行 Statistics 命令之前显示对象相应的标量值(树视图中的表示功能)。

此功能面向持有 Standard 许可的用户提供。

LGSx 集成更新

Cyclone 3DR 2024.1 在 LGSx 文件处理方面继续改进,包括在不将 LGSx 转换为 Cyclone 3DR 原生格式的情况下支持更多功能与函数、显示轨迹,以及在 Cyclone 3DR Free Viewer 中支持 LGSx。

支持原生 LGSx 图像

用户现在可以无需任何转换步骤,直接从 LGSx 文件流式传输全景图像。这一改进为用户提供了在图像中漫游并在 3D 场景中显示图像的可能性,适用于所有不需要转换 3DR 原生格式的工作流。

Cyclone3DR 2024.1 流式 LGSx 图像选项 01

用户将立即能够:

  • 借助 Visual Notes 通过 LGSx 对竣工情况进行可视化报告。
  • 借助图像,使用 Virtual Surveyor 基于点选择进行提取。
  • 使用 Cyclone 3DR 2024.0 所有最新发布的导航工具。

说明

关于 LGSx 图像使用的说明

  • 当用户选择该选项时,第一个上传阶段会更长,因为所有图像都会被预加载。某些工作流可能并不需要图像。在这种情况下,建议取消勾选该选项。
  • 流式传输的图像会加载到缓存中,在保存 3DR 项目时不会保存到文件夹中。只要 LGSx 文件与 3DR 项目保持关联,稍后再次打开项目时仍可以访问这些流式传输的图像。
  • 要执行需要图像的纹理功能,必须从 LGSx 项目转换图像。相关要求详见本章节:https://hexagonmi.atlassian.net/wiki/spaces/RCD/pages/edit-v2/44135007535#Compatibility-with-native-JetStream-point-clouds
  • 在一个 Cyclone 3DR 项目中可以同时存在流式传输的图像和转换后的图像:

image-20240702-130455.png

支持 LGSx 轨迹(Tracks)

自动导入

当把 LGSx 项目导入 Cyclone 3DR 2024.1 时(无需任何转换步骤),对于所有移动扫描仪项目(BLK 移动传感器和 TRK 系列),轨迹/tracks 都会被自动导入并转换为 Cyclone 3DR 中的轨迹对象。

用户不再需要经过转换到 Cyclone 3DR 原生格式的步骤,即可在 Cyclone 3DR 中使用轨迹资产。此外,用户现在可以:

  • 从轨迹的曲线轴创建裁剪剖切
  • 在脚本工作流中利用轨迹实现更多自动化

此改进不会影响体验的性能,因为轨迹是非常轻量的资产。

此功能面向持有 Standard 许可的用户提供。

image-20240702-115503.png

从轨迹创建组

在导入包含轨迹的 LGSx 文件时,用户现在可以基于轨迹对象将项目拆分为多个组。这意味着在转换 LGSx 项目之后,每个组由以下内容组成:

  • 一个独立的点云
  • 一组图像(根据用户的选择流式传输或转换 — 上一章节中已有描述)
  • 一条轨迹

此改进让用户能够快速隔离并专注于数据的相关部分。

image-20240702-121220.png

此功能面向持有 Standard 许可的用户提供。

Cyclone 3DR Viewer 支持 LGSx

Cyclone 3DR Viewer 现在支持流式传输 LGSx 项目,其选项和能力与常规 Cyclone 3DR 应用程序相同,包括:

  • 点云
  • 图像
  • 轨迹

Cyclone 3DR Viewer 可通过以下平台免费按需获取:https://leica-geosystems.com/products/laser-scanners/software/leica-cyclone/leica-cyclone-3dr/leica-cyclone-3dr-download

此功能面向持有免费 Cyclone 3DR Viewer 的用户提供。

点云属性更新

Cyclone 3DR 2024.1 现在会存储并公开额外的点云属性,以更好地管理点云信息、优化清理,或将点云数据用于分析和报告。

所有点云属性功能均面向持有 Standard 许可的用户提供。

按属性分离

Cyclone 3DR 2024.1 中公开了一个新的智能分割功能,允许用户按属性分割点云的某个部分。这一新功能提供了一种统一的方式来按以下属性进行分割:

  • 基于索引的属性:
  • Classification:按类别分割
  • Return Type:Cyclone 3DR 2024.1 中新支持的属性,此处有说明 https://hexagon.atlassian.net/wiki/spaces/RCD/pages/edit-v2/44135007535#Support-of-return-type-values
  • 基于标量值或颜色渐变的属性:
  • Intensity:按值范围分割
  • Inspection:按在 Cyclone 3DR 中执行的检查分析的值范围分割
  • Timestamps:按值范围分割
  • Density:按值范围分割,使用 2 个脚本函数之一计算:ComputeDensityFromNearestPoints() 或 ComputeDensityFromSphere()

Separate by Attributes 取代并整合了若干旧命令,其用途同为点云分割。以下命令已弃用。

  • Explode by Class
  • Scalar Steps
  • Scalar Range

新的点云分割工作流如下:

  • 选择一个点云
  • 从 Clean 菜单执行 Separate by attributes
  • 选择合适的属性来分割输入点云。
  • 默认情况下,首先显示可见属性。
  • 仅显示可用的属性。
  • 对于基于标量值的属性,打开和关闭 Use gradient intervals 开关可在不同选择模式之间切换
image-20240628-153124.png image-20240628-153254.png

如果所选属性基于索引或基于标量值,则会向用户显示两种不同的界面:

基于索引的属性菜单

会显示属性列表并带有复选框,以帮助用户定义输出的点云。

image-20240628-154404.png

image-20240628-154816.png

基于标量值的属性菜单

如果颜色渐变由范围组成,则可以按范围自动分割,从而简化体验。

image-20240628-154120.png

或者,关闭 Use gradient intervals 开关以显示滑块来定义值的范围。

image-20240628-153829.png

点云按上述方法分割后,用户可以进一步调整输出和点云的可见性。

  • 复选框用于定义是否将子点云保存为输出。
  • 灯泡图标用于管理子点云在 3D 场景中的可见性。
  • 撤销/重做
  • 使用对话框底部的按钮,或 Ctrl+Z、Ctrl+Y。
  • 合并子选集(合并后属性仍会保留)
  • 选择多个属性并右键单击,选择 Group selected clouds
  • 重命名子选集(通过右键单击)
  • 移除子选集
  • 使用属性名称右侧的 X 按钮

image-20240722-082345.png

支持 return-type 值

新属性

Cyclone 3DR 2024.1 现在支持 LAS、LAZ 和 E57 格式的 return-type 值(基于激光扫描仪模式)。这些值作为导入点云的新属性公开,从而解锁了一种新的表示方式。

这一新功能适用于能够提供 return-type 值的扫描仪,主要是移动测绘扫描仪(TRK 系列)和航空传感器。

3DR 2024.1 ReturnType 树视图 放大

return type 值分为 5 组:

  • Single
  • First of multiple
  • Intermediate
  • Last of multiple
  • Undefined

return type 在 LAS/LAZ 和 E57 格式的导入与导出中均受支持。

新的分割工具 Separate by Attributes 与这一新属性兼容。用户现在能够根据这些属性高效且准确地清理点云。一个典型应用是轻松移除植被以生成准确的 DTM。

3DR 2024.1 ReturnType Insbruck UAVjpg

新设置

为支持新的 return-type 值,设置中公开了新的颜色参数,供用户自定义表示方式。它们可在 Settings 的 Display > Cloud 菜单中访问。

image-20240722-083454.png

导入时按属性筛选 LAS/LAZ

在 Cyclone 3DR 2024.1 中,用户现在可以在导入前按特定属性筛选 LAS/LAZ 格式,以优化导入,并在数据对应用无用时减小数据大小。LAS 和 LAZ 数据可以按以下条件筛选:

  • Intensity
  • Classification
  • Return-Type

除这一层筛选之外,当选择导入 classification 时,还可以按类别进行筛选。这可以进一步减小数据大小,仅导入目标应用所需的点。

例如,用户在进行 Cyclone 3DR 中的 DTM 创建时可能不希望保留植被,如下图所示。

加载 LAS 或 LAZ 文件时,会向用户显示其属性列表,用户可以使用复选框选择或取消选择要导入的属性。

image-20240726-075858.png

Connect to Reality Cloud Studio 更新

在 Cyclone 3DR 2024.1 中,从 Reality Cloud Studio 流式传输的点云可以存储更多属性:

  • Timestamps
  • Classification

如果原生点云包含此类信息,这些属性将被自动存储。可以转换点云并保留 timestamp 和 classification 属性,以便使用应用程序的高级分割工具来完成工作流。

在 Cyclone 3DR 2024.1 版本中,请注意只能从流式传输的 Reality Cloud Studio 点云中可视化 classification 属性。将流式传输的对象转换为 3DR 点云后,即可可视化 “timestamps” 属性。

image-20240722-084412.png

使用 Connect to Reality Cloud Studio 功能需要 Reality Cloud Studio 凭据。

Intensity 和 Inspection 属性的改进

随着 Cyclone 3DR 2024.1 的发布,现在可以同时存储 intensity 和 inspection 值属性。相比此前版本的 Cyclone 3DR,这一改进确保用户无需在与其点云相关的信息上做出取舍,为他们提供尽可能广泛的属性范围以进行分割。

image-20240628-152434.png

扫描方向

对于存储了扫描方向的点云,对象的表示面板中提供了一个新功能,并公开了一个开关,允许用户显示或隐藏扫描方向。

静态传感器能够为点云生成扫描方向信息,LGSx 和 e57 是将它们导入 Cyclone 3DR 的合适格式。

image-20240612-103638.png

当扫描方向有助于在 3D 网格化过程中可视化所使用的扫描方向时,此功能对高级网格化工作流很有用。

image-20240612-103138.png

image-20240722-083621.png

改进

  • 3D Scene > Background: 提供了与 Reality Cloud Studio 保持一致的新 SkyBox 背景。

image-20240704-134622.png

Cyclone3DR 2024.1 SkyBox 深色 Cyclone3DR 2024.1 SkyBox 浅色 Cyclone3DR 2024.1 SkyBox 云彩
  • 3D Scene > Camera: 在缩放时引入了 “平滑滚动” 效果。
  • 3D Scene > Rendering engine improvement: 针对孤立点、多段线和文本的渲染引擎得到改进,当 3D 场景中可见大量多段线(尤其是被检查的多段线)时,可带来显著的性能提升。一些示例如下:
  • Profile 2D or 3D Analysis 用于非常庞大的数据集,这在移动测绘应用中很常见
  • 重复性检查,例如 Tank Inspection 工作流中详细的 Verticality 或 Roundness 验证。
  • Application > Icons: 大多数 Ribbon 图标已通过新设计实现现代化,以在所有实景采集产品中遵循统一的风格与图标体系。
  • Analysis > Compare/Inspect Section vs Section: 向用户公开了一个新选项,用于反转偏差值。
  • View > Image navigation toolbar: 添加了一个通用可见性开关,用于控制整个项目中的图像位置可见性。

image-20240628-124821.png - Import > From Cyclone FIELD 360: - 点的颜色显著改进(现在基于 HDR 图像)。 - BLK360 扫描中不需要的黑色区域现已移除。 - View > Clipping object editing: 编辑裁剪对象(剖切和盒体)时,编辑快捷键已更改,以提升应用程序内的一致性: - ESC:取消编辑 - ENTER:验证编辑 - Script: 公开了一个新的脚本函数 SCloud.HasIntensity(),以厘清 inspection 与 intensity 属性之间的用法。 - Texturing > Adjust Texture: 添加了一个按钮,用于从 3D 场景中选择纹理。 - Texturing > Estimate Pose: 新增将结果导出到报告的能力。

image-20240628-151539.png image-20240628-151826.png - Texturing > Smart Texture: 用于满足过渡区混合需求的模糊效果已被显著去除。

传感器 使用 Cyclone 3DR 2024.0 使用 Cyclone 3DR 2024.1
BLK2FLY Cyclone3DR 2024.1 SmartTexture BLK2FLY 之前 Cyclone3DR 2024.1 SmartTexture BLK2FLY 之后
BLK2GO PULSE Cyclone3DR 2024.1 SmartTexture BLK2GO PULSE 之前 Cyclone3DR 2024.1 SmartTexture BLK2GO PULSE 之后
BLK360 Cyclone3DR 2024.1 SmartTexture Church 之前 Cyclone3DR 2024.1 SmartTexture Church 之后

已修复问题

  • Clean > Join Polylines: 修复了一个阻止用户捕捉到所有端点的缺陷。
  • Report: 修复了一个导致标签在高分辨率图像中重复出现的缺陷。
  • Script > ExportOrthoimage(): 移除了关于导出的正射影像尺寸(宽度和高度)仅限整数值的限制。这为创建多个正射影像提供了更大的灵活性。
  • Surface Modeling > Clean / Separate: 修复了一个在处理位于大坐标处的网格时可能导致选择不准确的缺陷。
  • Windows Explorer: 修复了一个导致 Cyclone 3DR 缩略图显示异常的缺陷。

已知问题

  • “Send to Hexagon MinePlan 3D” 功能在 Cyclone 3DR 2024.0 中失效。当前的变通方法是通过 CAD 文件(如 DXF 格式)交换数据。
  • Documentation Center 仅提供英文版本。
  • 可能会出现一些 CAD 导入和导出问题。建议使用 Send to CAD 功能。
  • 如果 DXF 可以用标准版本导入,则 DWG 需要 AEC 或 PRO 版本。一种变通方法是使用 AutoCAD 中的 3DR Send 命令发送到 Cyclone 3DR。

已弃用功能

Leica Geosystems 致力于在现有技术以及第三方合作伙伴所能提供的支持所允许的合理范围内,为尽可能广泛的操作系统和文件格式提供支持。

每次发布时,我们都会根据行业趋势和已宣布的产品停用情况,审查当前受支持的格式与操作系统列表。

Leica Geosystems 可能会在任何一次发布中新增或终止对某种文件格式的支持。已过时的操作系统将在其宣布停用后或下一次主要软件发布后(以先到者为准)继续获得六个月的支持。服务器产品将按照 Leica 的 Client License Manager(CLM)所支持的服务器提供支持,以防用户遇到不兼容问题。

Cyclone 3DR 2024.1.0:

  • CloudWorx > Connect to JetStream Enterprise: JetStream Enterprise 自 2021 年起开始逐步淘汰,已移除与该产品的连接。
  • Clean > Explode by Class:已被 Separate by Attributes 取代
  • Clean > Scalar Steps:已被 Separate by Attributes 取代
  • Clean > Scalar Range:已被 Separate by Attributes 取代

通用规格

Leica Cyclone 3DR 2024.1 兼容性

  • Cyclone 3DR 与 CLM 2.14.0 及更高版本兼容。
  • Cyclone 3DR 与 LGS/LGSx 文件兼容。
  • Cyclone 3DR 与 Cyclone ENTERPRISE 2022.0 及更高版本兼容。
  • Cyclone 3DR 与 Cyclone REGISTER 360 2021.1 及更高版本兼容。
  • Cyclone 3DR 与 Cyclone 6.0 或更高版本创建的 Cyclone IMP 数据库兼容,但只有使用 Cyclone 9.3 或更高版本创建的 IMP 才能看到改进的渲染效果。

推荐计算机配置

桌面应用程序中的常规工作流:

  • CPU:2 GHz 双四核 i7 或更高(最低 i5)
  • 64 位操作系统的 RAM:
  • 最低 16 GB
  • 建议 32GB 或更多
  • 显卡:NVidia Quadro 或 GeForce 1 GB(支持 OpenGL,版本 4.3 或更高)
  • 操作系统:Microsoft Windows 10(Build 1809)、11(支持 64 位)
  • 硬盘:3 GB 可用磁盘空间

用于 Touch Mode 的平板设备:

  • Microsoft Surface PRO Core i7 1.5 GHz – 16GB RAM。

自动分类的最低配置(在桌面应用程序其他推荐配置之外另需:

  • RAM:最低 32 GB
  • 显卡:具备 GPU 能力的 NVidia
  • 计算能力:5.0 或更高
  • 最低 GPU 显存:4 GB
  • 硬盘:10 GB 可用磁盘空间
  • CUDA® 11.8 Toolkit(来自 NVidia)。自动分类必须使用 CUDA 11.8 版本。

安装与许可建议

安装更新流程

  1. 启动 Cyclone 3DR EXE 并按照安装向导中的说明操作

image-20240712-073001.png 2. 选择更新 Cyclone 3DR 的选项(如果想更改安装选项,则选择修复)

image-20240712-073028.png 3. 选择 “Install” 完成安装。

image-20240712-073101.png

许可设置

  1. 安装 Cyclone 3DR 后,通过 Cyclone 3DR(Home/Settings/License)或通过以下位置的程序打开用于 Floating 许可的 Client License Manager:

Start Menu | All Programs | Leica Geosystems | Client License Manager

image-20240712-073453.png

注意

务必选择 CLM Floating 选项(有两个 CLM 选项,Nodelocked CLM 不会激活您的许可)。

image-20240712-072648.png 2. 单击 Add。 3. 在字段中输入您的 Entitlement ID(EID)(复制 / 粘贴)。如需输入多个 EID,请用分号 “;” 分隔,且不加空格。

image-20240712-072821.png 4. 输入 EID 后,单击页面右下角的 Add 按钮。 5. 许可激活后,您可以关闭 CLM 并启动或返回 Cyclone 3DR。

image-20240712-074422.png 6. 转到 Home | Settings 并选择 License。

image-20240712-074031.png 7. 如果您已在本地 CLM 中输入 EID,请选择 Localhost。如果许可位于专用服务器上,请在 Server Address 中输入服务器名称。

image-20240712-074212.png 8. 您可以选择要从 CLM 检出的功能。可检出的选项与您购买并包含在 EID 中的选项相对应。

image-20240712-074249.png 9. 选择完选项后,单击 Activate license。

image-20240712-074329.png

许可

所有持有 Cyclone 3DR 有效 CCP 或截至 2024 年 7 月 6 日有效的 CCP 的用户,均可运行此新版本的 Cyclone 3DR。

所有持有 3DReshaper 有效 CCP 或截至 2024 年 7 月 6 日有效的 CCP 的用户,均可运行此新版本的 Cyclone 3DR,无需新的许可。持有 CCP 已过期的 3DReshaper 许可的用户必须迁移到 Cyclone 3DR,才能继续获取更新与支持。如需了解更多信息,请联系您的销售或支持人员。

所有持有 Cyclone SURVEY 有效 CCP 或截至 2024 年 7 月 6 日有效的 CCP 的用户,均可运行此新版本的 Cyclone 3DR(仅限 Standard 和 Survey Edition 功能)。

所有持有 Cyclone MODEL 有效 CCP 或截至 2024 年 7 月 6 日有效的 CCP 的用户,均可运行此新版本的 Cyclone 3DR(仅限 Standard 和 Plant Edition 功能)。

互操作性

导入 / 导出支持的文件格式

请参阅 Cyclone 3DR Technical Specification,获取各许可所支持文件类型的完整列表。

导入 导出
点云 ASCII 文件(.asc、.csv、.xyz、.yxz…)Leica Geosystems(.pts、.ptx)及 LGS/LGSX(.LGS/LGSx)Leica Nova MS50/60(.sdb、.xml)ShapeGrabber(.3pi)3DReshaper 二进制文件(.nsd)AutoDesk DXF(.dxf)STL(.stl)Polyworks(.psl)Leica T-Scan + Steinbichler(.ac)LIDAR 数据(.las; laz)其他 ASCII(.)Zoller 和 Fröhlich (.zfs - .zfc) 无三角面的 PLY 点(.ply)ESRI ASCII(栅格格式 .asc)FARO(.fls - .fws)POLYWORKS(.psl)E57(.E57 文件)LandXML 文件(.xml)Riegl(.RDBX) ASCII 文件(.asc、.csv…)二进制文件(.nsd)Leica Geosystems(.pts、.ptx、LGSx)E57(.e57)IGES(.igs)LAS(.las)LAZ(.laz)Autodesk DXF(*.dxf)
网格 STL 格式(.stl)二进制 PBI 格式(.pbi)DXF 3Dface 格式(.dxf)ASCII POLY 格式(.poly)OBJ 格式(.obj)ASCII Leica 格式(.msh)OFF 文件(.off)PLY(.ply)GLB 格式(.glb、gltf) ASCII 与二进制 STL 格式(.stl)二进制 PBI 格式(.pbi)DXF 3Dface 格式(.dxf)ASCII POLY 格式(.poly)仅顶点(.asc)DXF 多段线(.dxf)ASCII Leica 格式(.msh)PLY(.ply)LandXML(.xml)OBJ 格式(.obj)GLB 格式(.glb)FBX 格式(.fbx)IFC / IFCSite 类型(.ifc、.ifczip)
等高线 / 剖面 IGES 格式 DXF 多段线格式 二进制 MLI 格式(*.mli) IGES 格式 DXF 多段线格式 二进制 MLI 格式(*.mli)ASCII 格式
CAD / BIM 模型 IGES STEP DWG IFC RVT IGES STEP DXF IFC(管道模型)
项目 Cyclone 3DR(*.3dr)DXF - DWG XML Cyclone ModelSpace View(来自 IMP) Cyclone 3DR(*.3dr)DXF PDF 3D SKETCHFAB
报告 PDF CSV BCF
图像 BMP JPEG JPG PNG 带地理配准信息的正射影像(以 TXT 文件形式)JPG JPEG BMP PNG TIF(仅正射影像)
轨迹(移动扫描仪) Leica Geosystems(*LGSx) Leica Geosystems(*LGSx)

Send To / Send From

Cyclone 3DR 也提供 “SendTo” 功能,用于与第三方产品相互导入和导出特定类型的数据。更多信息请参阅 Cyclone 3DR 文档中心(可从软件的帮助菜单进入)。

Send From Send To
点云 - -
网格 / 曲面 Autodesk AutoCAD Hexagon MinePlan 3D Hexagon BricsCAD Autodesk AutoCAD Hexagon MinePlan 3D Hexagon BricsCAD
等高线 / 剖面 / 点 Autodesk AutoCAD Hexagon MinePlan 3D Hexagon BricsCAD Autodesk AutoCAD Hexagon MinePlan 3D Hexagon BricsCAD
CAD 模型 Autodesk AutoCAD Hexagon BricsCAD -
图像 - Autodesk AutoCAD(正射影像)Hexagon BricsCAD

Cyclone 3DR 中的以下命令包含直接的 “Send to” 能力,可将输出导出到 CAD 第三方软件产品的不同图层中:

菜单 功能 备注
Extract Contour Lines 标准等高线及其数值 1 个图层。主要等高线及其数值 1 个图层。
Extract Scan to Plan 每个剖切(平面图或剖面)1 个图层
Extract Virtual Surveyor 3DR Virtual Surveyor 项目中每创建一个图层对应 1 个图层。
Extract Scan to Pipe 每条管道轨迹 1 个图层
Analysis Gridded Inspection Surface Analysis with a Grid 网格上的点和数值可直接发送到 CAD 软件产品。发送到活动图层。
Texturing Extract Orthoimage 发送到活动图层。
Analysis Profile Extraction Profile 3D Inspection Profile 2D Inspection 2D 网格 1 个图层 检查对象 1 个图层 每个剖面 1 个图层 每个轴点 1 个图层 每个轴点标注 1 个图层。
Tank 2D Preview / Export

与原生 JetStream 点云的兼容性

以下命令可使用原生 JetStream 点云(LGS/LGSX 文件,或连接到 Cyclone CORE、Cyclone REGISTER 360、Cyclone ENTERPRISE)作为输入。换言之,在执行所列功能之前无需先进行 CloudWorx > Convert project 步骤。

菜单 功能 备注
Extract Virtual Surveyor 此功能无需选择对象。因此,它可用于 3DR 项目中的任何类型的对象。
Extract Scan to Plan
Surface Modeling Scan to Mesh 建议将裁剪盒作为输入,以定义感兴趣区域。
Analysis Stockpile
Analysis FF/FL Analysis 工作流的第一步会显示最大点数。建议保留较高数值,以便在密集点云上执行准确分析。
Analysis Visual Notes 此功能无需选择对象。因此,它可用于 3DR 项目中的任何类型的对象。

View、CloudWorx 和 Script 菜单的功能显然也可用于 JetStream 点云。

自 Cyclone 3DR 2024.1.0 版本起具备从 LGSx 文件流式传输图像的能力,不再需要转换项目即可查看相机图像。但是,当图像用于特定功能时,仍然必须进行转换:

菜单 功能 备注
Texture Smart Texture Standard Texture Edit Mask 当用户预期使用图像进行纹理工作流时,必须从 LGSx 转换图像。
Image object usage Group / Ungroup 在树视图中,只有从 LGSx 文件转换后的图像才能编组和取消编组。

连接到 Cyclone FIELD 360

从 Cyclone FIELD360 到 Cyclone 3DR(2024.0 及更高版本)项目的连接仅限于 TLS 传感器:

  • P-Series
  • RTC360
  • BLK360、BLK360 G1

导出 BCF 工单

以下命令具备导出 BCF(BIM Collaboration Format)文件的能力,这些文件包含来自 IFC 模型的信息,可与其他软件和 BIM 解决方案实现开放式 BIM 体验。

Cyclone 3DR 2024.1 支持 BCF 2.1 格式(导出)。

菜单 功能 备注
Analysis Inspection Notes 输入:受检查的 BIM 模型 用于报告检查中发现的问题的功能,可创建手动注释,注释包含截图、磁盘中的图像、标签和偏差值(附 CSV)、裁剪对象信息以及视点的坐标与朝向;此外还包含用户自定义标题、指派对象(电子邮件地址)、评论和优先级。
Analysis Visual Notes 输入:BIM 模型 用于基于 BIM 设计模型与实景采集数据的可视化分析来报告评论和注释的功能。该功能可创建手动注释,注释包含截图、磁盘中的图像、距离测量、裁剪对象信息以及视点的坐标与朝向;此外还包含用户自定义标题、指派对象(电子邮件地址)、评论和优先级。
Analysis Clash 输入:点云和 BIM 模型 用于报告碰撞的功能,碰撞信息包含截图、碰撞状态(碰撞、无碰撞或未定义)和评论。所有工单都指向同一个指派对象(电子邮件地址)。
Analysis Progress Monitoring 输入:点云和 BIM 模型 用于报告进度监测分析的功能。默认导出包含摘要(已安装、进行中、未安装和无数据之间的进度分布)。可自定义导出,并可根据每个分析元素的状态(已安装、未安装、进行中)为其创建额外的单独工单。所有工单都指向同一个指派对象(电子邮件地址)。
Touch Mode BIM Inspection 输入:点云和 BIM 模型 “Touch Mode” BIM Inspection 工作流也提供创建 BCF 问题的方式。其内容与从 “Inspection notes” 导出的注释类似,后者是 BIM Inspection 的桌面等效功能。

分类体验

分类的交换格式

点云分类会保存并支持以下交换方式:

  • 导入和导出:LGSx、E57、LAS、LAZ
  • 流式传输和转换:来自 Reality Cloud Studio, powered by HxDR

模型

在 Cyclone 3DR 2024.1 版本中,自动分类功能提供以下分类模型。

名称 应用 用于训练的扫描仪 其他建议 使用分类信息的功能
Indoor Generic 室内 – 全部 全部 与 Scan to Model 工作流相关。
Indoor Construction Site 室内 – 全部 全部 与 “Scan to Verify” 工作流相关,例如用于竣工验证。 Progress Monitoring
Outdoor for TLS 室外 – 全部 TLS 通用分类,可与其他传感器类型配合使用。
Heavy Construction UAV 室外 - 重型施工 UAV 传感器 仅建议用于重型施工环境。可与其他传感器类型配合使用。 适合在 Virtual Surveyor、DTM 之前执行
Mobile BLK Filter People 全部 BLK2GO 和 BLKARC 仅建议配合 BLK2GO 和 BLKARC 使用。清除移动的人员和物体。
Road for MMS 道路 TRK 系列 建议配合所有 MMS 传感器使用,配合 RTC360 和 BLK360 等 TLS 扫描仪进行提取时也很有用。 适合在 Virtual Surveyor、DTM 之前执行
Plant 工厂设施、MEP 环境 全部 建议配合静态扫描仪使用 适合在 Scan to Pipe 之前执行